Błędy (jakie napotkałem) i uwagi (jakie mam) do aplikacji

Błędy zgłaszane przez użytkowników i administrację
Hannibal
Posty: 2
Rejestracja: śr maja 30, 2018 2:41 pm

Błędy (jakie napotkałem) i uwagi (jakie mam) do aplikacji

Post autor: Hannibal » wt cze 26, 2018 8:24 pm

Jako że to jest mój pierwszy post, witam wszystkich!

W aplikacji napotkałem kilka błędów:
  1. Kod wybierający rozdzielczość aparatu jest nieprawidłowy. Zakłada on że system, wpisując dostępne, zwraca rozdzielczości od najmniejszej do największej co nie jest zawsze prawdą. Powoduje to że rozdzielczość "podglądu" może być mniejsza od "pełnej". Aplikacja powinna sprawdzać faktyczne rozmiary a nie wybierać "środkowej" dla podglądu i "ostatniej" dla pełnej rozdzielczości.
    https://github.com/credo-science/credo- ... /issues/35
  2. Statystyki dla nerdów nie mieszczą się na wąskich ekranach, np takich jak w Samsungu Galaxy S2, który to ma tylko 320dp szerokości. Aplikacja powinna zmniejszyć czcionkę dla niskich szerokości lub jakoś inaczej te dane sformatować.
    https://github.com/credo-science/credo- ... /issues/36
  3. Na Samsungu Galaxy S3 aplikacja ciągle woła aby zakryć kamerę mimo że jest zakryta. A po jakimś czasie zamyka się. Nie mam tego urządzenia cały czas więc proszę traktować ten opis jako przypuszczenia. Z "adb logcat" wyczytałem że proces aparatu nie jest w stanie zmieścić danych podglądu w buforze przygotowanym przez aplikację. Ten błąd powodował próbę zgłoszenia problemu przez ACRA'ę która z powodu jakiegoś błędu SSL powodowała wyjątek zamykający w końcu aplikację :mrgreen: . Przypuszczam że aparat w S3 wysyła podgląd w formacie RGB a aplikacja spodziewa się go w YUV który potrzebuje mniejszych buforów. IMHO, aplikacja powinna ustawiać format podglądu bezpośrednio a nie polegać na domyślnym. Do tego powinna wykorzystywać podglądy RGB jeśli są dostępne gdyż i tak później do tego formatu przekształca podglądy YUV. Powinno zmniejszyć to trochę bateriożerność.
    https://github.com/credo-science/credo- ... /issues/37
  4. Administracja powinna pojawiać się na forum trochę częściej. Miesiąc na aktywację konta to trochę słabo :/
Było by też przydatne aby można było w ustawieniach podać identyfikator urządzenia i aby był on widoczny na stronie tak aby użytkownicy mogli śledzić na jakim ich urządzeniu dana detekcja zaszła.

Na koniec mam też pytanko. Czy https://github.com/credo-science/credo- ... r-android/ to oficjalne źródło projektu czy jakaś kopia "społeczna"?
Pytam bo kod nie do końca jest zgodny z tym co widzę w aplikacji...
Hannibal@Slackware-current

phomola
Site Admin
Posty: 20
Rejestracja: pn lis 13, 2017 1:48 pm
Kontakt:

Re: Błędy (jakie napotkałem) i uwagi (jakie mam) do aplikacji

Post autor: phomola » pn lip 02, 2018 7:19 pm

Bardzo dziekujemy za te zgloszenia! Na github jest oficjalna wersja, powinno byc dokladnie to co widac Google Play, jesli jest inaczej to prosze tez zglosic w issue. Co do nieobecnosci administracji na forum to calkowita zgoda, czlowiek odpowiedzialny za to juz z nami nie pracuje i chyba dobrze, tez nie wiem czym mozna wytlumaczyc az miesieczne oczekiwanie na aktywacje konta, jako liderowi projektu jest mi bardzo przykro z tego powodu, przepraszam w imieniu CREDO i jednoczesnie gratuluje ze sie Pan nie zniechecil... Jeszcze co do github i forum: zachecam serdeczenie do wlaczenia sie w development i w forum, co do tego ostatniego bedziemy przyznawac uprawnienia najbardziej aktywnym uzytkownikom chetnym do pomocy, przed chwila np. uprawnienia zgodzil sie przyjac i przyjal mpknap :)
Piotr Homola
CREDO leader
credo.science/homola

Enerdhil
Posty: 37
Rejestracja: czw lis 16, 2017 9:52 pm

Re: Błędy (jakie napotkałem) i uwagi (jakie mam) do aplikacji

Post autor: Enerdhil » pn lip 02, 2018 7:50 pm

Co do galaxsy s3. Mam Galaxsy S3 na detekcji 24h. Wszystko jest w porządku.

Hannibal
Posty: 2
Rejestracja: śr maja 30, 2018 2:41 pm

Re: Błędy (jakie napotkałem) i uwagi (jakie mam) do aplikacji

Post autor: Hannibal » pn lip 02, 2018 9:19 pm

Enerdhil pisze:
pn lip 02, 2018 7:50 pm
Co do galaxsy s3. Mam Galaxsy S3 na detekcji 24h. Wszystko jest w porządku.
Być może to kwestia ROM-u jaki tam był (AKOP czy coś takiego) albo inna wersja S3, bo było ich - kilka ten który testowałem to chyba była wersja LTE.
Hannibal@Slackware-current

ODPOWIEDZ