Brak detekcji

Jeśli czegoś nie wiesz zadaj tu pytanie
mmateja
Posty: 55
Rejestracja: pn lis 13, 2017 1:54 pm

Re: Brak detekcji

Post autor: mmateja » czw lis 16, 2017 10:29 am

dariusz.d pisze:
śr lis 15, 2017 10:31 pm
Zauważyłem właśnie, że aplikacja ogólnie działa. Miałem telefon z niezaklejonymi kamerami zamknięty w pudełku. Musiałem odebrać jak zadzwonił i nie wyłączyłem detektora - po skończonej rozmowie było naliczone ponad 100 detekcji (jak mniemam fałszywych). Czyli aplikacja wydaje się współpracować z urządzeniem (i systemem), ale w takim razie nie wiem czego to może być problem. Może nie każdy aparat nadaje się na wykrywacz?
Możliwa jest taka ewentualność - będziemy testować. Dziękujemy za feedback!

Enerdhil
Posty: 37
Rejestracja: czw lis 16, 2017 9:52 pm

Re: Brak detekcji

Post autor: Enerdhil » pt lis 17, 2017 11:06 am

Totalny brak detekcji a mam włączoną apkę bez przerwy od 3 dni. Natomiast z łatwością potrafię wygenerować artefakty wystarczy że zamknę telefon z odkrytym aparatem w ciemnej łazience i na sekunde uchyle drzwi na milimetr. Czyli apka działa ale u mnie nie w zakresie detekcji. Nie wiem czemu. Android 7 samsung galaxy A5 2017. Dodatkowo Credo bierze stosunkowo mało energii jedynie 5% całego zużycia energii z całego dnia. Dodatkowo bezpośrednio po starcie detekcji w aplikacji aplikacja zajmuje mi latarke nie odpala jej ale zajmuje na jakies 5min a potem sama zwalnia.

mmateja
Posty: 55
Rejestracja: pn lis 13, 2017 1:54 pm

Re: Brak detekcji

Post autor: mmateja » pt lis 17, 2017 3:23 pm

Enerdhil pisze:
pt lis 17, 2017 11:06 am
Totalny brak detekcji a mam włączoną apkę bez przerwy od 3 dni. Natomiast z łatwością potrafię wygenerować artefakty wystarczy że zamknę telefon z odkrytym aparatem w ciemnej łazience i na sekunde uchyle drzwi na milimetr. Czyli apka działa ale u mnie nie w zakresie detekcji. Nie wiem czemu. Android 7 samsung galaxy A5 2017. Dodatkowo Credo bierze stosunkowo mało energii jedynie 5% całego zużycia energii z całego dnia. Dodatkowo bezpośrednio po starcie detekcji w aplikacji aplikacja zajmuje mi latarke nie odpala jej ale zajmuje na jakies 5min a potem sama zwalnia.
Przyjrzymy się problemowi - możliwe, że jest to problem z wersją systemu (mamy już kilka zgłoszeń na Androida 7.x) bądź z modelem. Dziękujemy pięknie za feedback!

Enerdhil
Posty: 37
Rejestracja: czw lis 16, 2017 9:52 pm

Re: Brak detekcji

Post autor: Enerdhil » pt lis 17, 2017 5:00 pm

Poczyniłem dalsze obserwacje. Okazuje się że kiedy CREDO przestaje samo z siebie bez uchwytnej przyczyny blokować dostęp do latarki wówczas również obserwuje z poziomu systemu operacyjnego że następuje koniec naliczania się wykorzystania przez CREDO aparatu oraz baterii pomimo że CREDO wciąż jest w statusie RUNNING oraz dodane jako wyjątek w systemie monitorowania i wyłączania aplikacji energochłonnych. Wygląda na to że CREDO potrafi zwolnić aparat i nadal wyświetlać status RUNNING. Pozdrawiam zespół. Robicie kawał świetnej roboty ;)

Nabialek
Posty: 12
Rejestracja: pt lis 17, 2017 8:38 am

Re: Brak detekcji

Post autor: Nabialek » ndz lis 19, 2017 10:35 pm

Po wyłączeniu powiadomień, przestała działać aplikacja. Od piątku nic nie wykrywa, a wcześniej takie kwiatki miałem https://api.credo.science/user/333
z czego może 4 to faktyczne detekcje..?

EMUI 4.1.3 (Android 6.0) procesor Kirin 620 - tel. CAM-L21 czyli Huawei Y6 II

Enerdhil
Posty: 37
Rejestracja: czw lis 16, 2017 9:52 pm

Re: Brak detekcji

Post autor: Enerdhil » pn lut 19, 2018 12:02 pm

Kolejne urządzenie SM-G903F zero detekcji od tygodnia i nigdy jej nie było.

mpknap
Posty: 60
Rejestracja: ndz lut 11, 2018 12:26 pm

Re: Brak detekcji

Post autor: mpknap » pn lut 19, 2018 5:45 pm

To i ja wrzucę tu swój model telefonu (do sprawdzenia):
LG-M200E
Android 7.0
Wersja Jądra 3.18.31

Jeszcze pytanie. Czy do detekcji konieczny jest sygnał, zasięg GPS? Czy jego brak ma wpływ?

..EDIT
No chyba jednak działa, po wieeelu dniach złapałem jedną. Być może dzięki patentowi, ukryłem telefon w dwóch czarnych grubych skarpetkach :D

mmateja
Posty: 55
Rejestracja: pn lis 13, 2017 1:54 pm

Re: Brak detekcji

Post autor: mmateja » wt lut 20, 2018 8:26 am

GPS nie powinien mieć wpływu na działanie aplikacji, w tym wykrywania cząstek) Cieszymy się, że udało się złapać cząstki! ;)

martina1224
Posty: 1
Rejestracja: śr paź 09, 2019 9:36 pm

Re: Brak detekcji

Post autor: martina1224 » czw paź 10, 2019 10:38 am

Włączam aplikację przy każdym ładowaniu telefonu (codziennie) od dwóch tygodni jak nie dłużej i kompletnie nic nie wykrywa. Mam samsunga galaxy s7 android 8.0.0.

slawekstu
Site Admin
Posty: 59
Rejestracja: pt lis 10, 2017 11:24 pm

Re: Brak detekcji

Post autor: slawekstu » czw paź 10, 2019 10:45 am

Najprawdopodobniej trzeba przeprowadzić kalibracje ręczną.
Czyli zmniejszyć wartości w ustawieniach dla
- max factor (każdy pixel ma wartość od 0 do 255, jeśli wartość pixela jest większa niż max factor zdjęcie uznawane jest za potencjalną detekcje)
np ze 100 na 90 czy 80

Tylko trzeba uważać by nie dać zbyt niskiej wartości (wtedy prawie każda klatka będzie uznawana za potencjalną detekcje mimo iż tak naprawdę większość będzie artefaktami)

ODPOWIEDZ